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Fig.1 Data import menu 
 

 

Working with Origin 8.6.  

Step1. Importing data 

 

 

Go to File menu, Import, choose what kind of data are you going to import. In the Fig 1 is the 

example of importing of the Simple Single ASCII data set. Your data will go to the current 

active worksheet (Data 1 in Fig1). After you have finished with the first data set you can import 
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Fig.2. Opening a new worksheet 

 
Fig.3. Multiple ASCII import 

any more data sets if it is necessary. Before importing a next data set you have to prepare a new 

worksheet. To do this - go to File menu then to New and you will see a new window (Fig.2). 

After a new worksheet is ready 

you can import a new data set. 

There is another option how to 

import several data files in one 

step. You have to choose a 

Multiple ASCII  option (Fig.1). 

This will result in appearance a 

new window (Fig.3.). Here you 

can find a proper place on your 

computer containing data files, 

then mark them and add to the 

list of the imported files (push 

Add file(s) button. Import 

could be done in three different 

ways: (i) you can load each file 

in a separated worksheet, (ii) 

you can import all data sets in the same one 

worksheet adding new columns to it, or (iii) you 

can import all data files in the same worksheet, 

but in new roes. Fig.3 shows the first option. 

After all files appeared in bottom window push 

OK and all data files will be downloaded in to 

the Origin worksheet(s). In case of Multiple 

ASCII data import you do not need to prepare 

worksheets for the new data sets – they will be 

created automatically.  At this point all data files 

are downloaded into the Origin project and you 

can start plotting the graphs and data analysis. 
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Fig.4.  

 
Fig.5 Plot Setup. 

2. Creating and editing the data plots.  

First open the worksheet which 

contains the data for plotting. Go to 

Plot menu and choose the kind of 

plot you like to create. In Fig.4 the 

Line and Symbol plot option is 

marked. It will be also possible 

latter to change this while editing 

the plot. It will be also possible to 

add more plots to the graph. After 

choosing the plot stile the Plot 

Setup window will invite to data 

selection dialog (Fig.5.). Here in 

the top window is the list of all 

available data worksheets. 

Middle part of the Plot 

Setup window is dedicated 

to make links between X 

and Y axes and the 

columns in the worksheet.   

yEr checkbox is to make a 

link to the column (if you 

have this data) containing 

Y axis error bars, L – the 

same for labels. To use any 

column as label column it 

should by initially assigned 

as Label column (right click on the column name and go Set as Label).  It is possible also to add 

X axis error bars on the plot. When you assigning the columns for X and Y axes you can mark 

several checkboxes for Y axis if it is necessary. After X and Y axes are chosen push Add and 

different information about the plot will appear in bottom window. While this dialog you can add 
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Fig.6. Graph window with X Y axes menu. 

as many plots to the graph as you need – check another worksheet and mark new columns as X,Y 

axes (yErr, xErr etc.).  After the dialog is done – push OK and all chosen data sets will appear in 

the same graph.  The graph which will open in the graph window will be very simple and you 

have to work on it a lot to bring to the level required for report or publication. To make a nicer 

design of the graph let we start to work on axes.   Click on X or Y axis and corresponding pop-up 

menu will appear (Fig.6.). Here you can change a lot of related to the graph design: type of the 

axis (linear, log10, ln etc.), scales, grids, tick labels, axes titles etc. You can easy switch from Y 

axis to X axis using selection window. The next what you can do with the graph is to work on 

plot design – line style, colors, etc. Click on the plotted line or go to the main menu Format  →   

Plot properties and  a new pop-up menu will appear on the graph (Fig.7).  At this point you can 

redesign each plot depicted in the active graph. You can do it separately with each plot or you 

can use the Group (see Origin manual how to use the Group option) option and do all changes in 

all presented plots in the same time. This could be very helpful if you work with a large number 
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Fig.7. Plot Details menu. 

 
Fig.8. Open template button  

of plots in the graph. In Fig.7 is shown the case of the “Line” Plot Type but if you will change it 

to “Line + Symbol”  there will two more submenus for Symbol style and Drop Lines editing.  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

After the graph design has been done you can 

save it as graph template for future use. Go to 

the main menu File → Save Template As. It 

will save your Graph without plots and you 

can use this template in this or in future 

project and it will save you a lot of time. To 

open a previously designed template you can 

use a special toolbar button (see Fig.8.). You can also use template provided by OriginLab. Go to 

Tools → Template Library. There is a huge selection of different templates but they are not 

ready for publication and you have work on Graph design (labels, axes names etc.).  One more 
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Fig.9. Tools toolbar 

 
Fig.10. Layers tool 

toolbar is very useful while working with graphs. Zoom 

in makes enlarging of the particular selected area by 

replotting of the data included in this area but not as a 

simple zooming of the graphical image. Screen reader 

shows X, Y coordinates of the screen in respect to 

scales of the axes. Data reader shows   X, Y 

coordinates of the selected data point in the graph. Data 

selector puts the limits for data in the graph which will 

be used in further data analysis (fitting, regressions 

etc.).  Regional data selector – selects data on active 

plot or plots. Regional mask tools – selects (deselects) 

data on active plot or plots – these points will be 

excluded from analysis. Draw data is for manual 

creating of the plot in the graph; corresponding data will 

go to a new worksheet. Text tool is for writing text in 

any place of the graphical page.  Arrow, line, circle 

tools are for adding to the Graph 

page some lines arrows etc. Insert 

equation – is a link to MathType, 

MSword. MSexcel to place the 

equation on the active graph. All 

these graphical elements will be 

saved when saving this graph as a 

template. You can add more layers 

or inserts to the graph. Go to Graph 

→ New Layer(Axes).  Some of 

those menu options are presented 

also in the Graph Toolbar (Fig.10).  

The layers on the page can be 

resized and rearranged by using 

Layer Manager (Graph → Layer 
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Fig. 12.Polynomial Fit menu. 

Manager).   

3. Data analysis and data fitting 

Linear fitting 

Origin provides a set of very powerful and convenient tools for data analysis and data fitting. To 

perform the polynomial fitting go Analysis → Fit Polynomial. The polynomial fit pop-up menu 

will appear 

(Fig.12).  This 

procedure works 

with graphical 

window and if 

you have several 

plots on the same 

graph go first to 

main menu Data 

and click on the 

data set you wont 

to work on. The 

next step is very 

simple you have 

to choose the 

Order of polynomial, Xmin and Xmax for fit curve and number of points for fit curve. To 

display the polynomial coefficients on the graph you have to check Show formula on Graph. 

The choice of Xmin and Xmax will not effect the fitting result – the entire data set will be used 

for fitting. To restrict the range of the data points involved in fitting you can use Data selector 

tool (see Fig.9). The maximum polynomial order number is 9. For fitting with linear function 

(polynomial order =1) you can use option Analysis → Fit Linear. It will do the same as Fit 

Polynomial with order =1.   
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Fig.13. Nonlinear fitting menu. 

Nonlinear fitting 

To perform the nonlinear fitting procedure go to main menu Analysis → Non-Linear Curve Fit 

→ Advanced Fitting Toll… The multilayer pop-up Nonlinear Fitting menu is shown in Fig. 13. 

Firs step – you have to choose from the library the fitting function or write your own function. 

The library Functions are grouped in several Categories. For each library Function you can 

the Equation, Sample Curve or Function File information (Sample Curve option in Fig.13). To 

write a new function - push User Function button and follow the instructions. There is a 

Replicas option for some 

functions (Multiple peak 

option in Fig.13.). It is very 

convenient tool for multiple 

peak fitting – you do not need 

to write equation for each 

peak but will need to do the 

some settings arrangement in 

submenu Replicas.  Data 

Selection submenu is for 

choosing of the data set or 

segment of data set for fitting. 

Start fitting (see below) will 

start the Fitting Session. Using the Simulation submenu you can plot the fitting curve or to play 

with initial parameters to manually optimize they.  Parameter constrictions submenu will set the 

constriction to the parameters during the fitting session. In Control parameters submenu you can 

adjust some fitting parameters such as tolerance factor, number of significant digits of the fitting 

parameters etc.  Initial parameters submenu is for enter that initial parameters, but the same you 

can do in Fitting session submenu. After fitting submenu gives some options how to plot final 

fitting curve. In Fig. 14 the Fitting session window is shown. The most important for successful 

fitting is the choice of the initial parameters. They can be entered in corresponding boxes (Value) 

here or in Initial parameters submenu. To start fitting push one of three buttons: “1 iter.”, “200 

iter.” or “200 Simplex iter.” Pushing “1 iter.” will results in singe iteration using Levenberg-

Marquardt (LM) algorithm, “200 iter.” – 200 LM iterations and “200 Simplex iter.”  - 200 
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Fig. 14. Fitting session Dialog box.  

Simplex iterations. Number “200” could be changed to 10, 30, 50 or 100 in Control parameters 

submenu.  Normally, you will not need to use the Simplex method because it is much less robust 

and reliable than the LM method.  However, if the LM method for a set of data behaves poorly, 

try the Simplex method. Some general recommendation of fitting procedure: (i) do not start with 

a big number of iteration until you are not sure that the process goes in the proper direction, (ii) 

in some cases helps to 

fix one or several 

parameters (uncheck 

corresponding 

checkboxes), (iii) try 

to change the value of 

some initial 

parameters if the 

fitting does not go 

well and start fitting 

again. After each 

iteration step or steps 

the fitting curve will 

be displayed in 

graphical window (red 

curve in the example 

shown in Fig.14). The 

criteria of end of 

fitting is if the 

Reduced Chi-sqr (see fitting protocol window) does not decrease more. Push Done and all 

fitting parameters and some complimentary information will be displayed in Graph.   

4. Worksheets 
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Fig.15. Working with worksheet. 

To perform some operations with worksheet first you have to open it. Next right click on the 

column header. Column becomes highlighted and a pop-up window appears. Here you can 

perform several useful operations on the worksheet. Set As will assign a column X, Y or Z (for 

3D graphs) axes data. Set Column Values option will perform some mathematical operation on 

the data from one or several columns. Sort Column and Sort Worksheet will perform sorting of 

the column or worksheet respectively. Statistics on Column will open a new worksheet 

containing all statistical information (Min, Max, Sum, etc.) on data set in the column. Properties 

will open a new pop-up window (not shown in Fig.15) and here you can change the Column 

Name, Column Label, Column Width, etc. You can also plot the data from the highlighted 

column (as Y axis data) in respect of previously assigned X column, but this way of creating a 
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plot is less convenient and less flexible as discussed above and shown in Fig.5. Some listed here 

operations you can do through the main menu → Column (see Fig.15).   

5. Final Comments 

 

Origin 7.5 provides much more features and opportunities to work with data and graphs than we 

discussed above. It has a powerful engine for 3D graphics, tolls for smoothing the data depicted 

in plots. You can apply (main menu Analysis) on the plotted data the Fast Fourier Transform 

(FFT), perform some math (Subtract → Strait Line or Reference Data) and Calculus 

(Differentiate, Integrate) operation on data in plots. Fitting to some typical (Exponential 

Growth. Exponential Decay etc.) functions can be performed very simple without opening  

Nonlinear Curve Fitting window  (Fig.14) – go to mane menu  Analysis and click on the listed 

function.  
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